Documentation

proteinplot

Open Protein Plot window to investigate properties of amino acid sequence

Syntax

proteinplot
proteinplot (SeqAA)

Arguments

SeqAA

Either of the following:

Description

The Protein Plot window lets you analyze and compare properties of a single amino acid sequence. It displays smoothed line plots of various properties such as the hydrophobicity of the amino acids in the sequence.

proteinplot opens the Protein Plot window.

proteinplot (SeqAA) opens the Protein Plot window and loads SeqAA, an amino acid sequence, into the window.

    Tip   You can analyze and compare properties of an amino acid sequence from the MATLAB command line also by using the proteinpropplot function.

Examples

Importing Sequences into the Protein Plot Window

You can import a sequence into the Protein Plot window from the MATLAB command line.

  1. Retrieve an amino acid sequence from the Protein Data Bank (PDB) database.

    prion = getpdb('1HJM', 'SEQUENCEONLY', true);
  2. Load the amino acid sequence into the Protein Plot window.

    proteinplot(prion)
    

    The Protein Plot window opens, and the sequence appears in the Sequence text box.

You can import a sequence after the Protein Plot window is open by doing either of the following:

  • Type or paste an amino acid sequence into the Sequence text box.

  • Click the Import Sequence button to open the Import dialog box From the Import From list, select one of the following:

    • Workspace — To select a variable from the MATLAB Workspace

    • Text File — To select a text file

    • FASTA File — To select a FASTA-formatted file

    • GenPept File — To select a GenPept-formatted file

    • GenPept Database — To specify an accession number in the GenPept database

Viewing Properties of Amino Acids

Select a property from the Properties drop-down list box to display a smoothed plot of the property values along the sequence. You can select multiple properties from the list by holding down Shift or Ctrl while selecting properties. When you select two properties, the plots are displayed using a PLOTYY-style layout, with one y-axis on the left and one on the right. For all other selections, a single y-axis is displayed. When displaying one or two properties, the y values displayed are the actual property values. When displaying three or more properties, the values are normalized to the range 0–1.

Accessing Information About the Properties

You can access information about the properties from the Help menu.

  1. Select Help > References. The Help browser opens with a list of properties and references.

  2. Scroll down to locate the property of interest.

Using Other Features in the Protein Plot Window

The Terminal Selection boxes (N and C) let you choose to plot only part of the sequence. By default, all of the sequence is plotted.

You can add your own properties by clicking on the Add button next to the Properties list. This opens a Property dialog box that lets you specify the value for each of the amino acids. The Display Text box lets you specify the text that will be displayed in the Properties list on the main Protein Plot window. You can also save the property values to a file for future use by typing a file name in the Filename text box.

The default smoothing method is an unweighted linear moving average with a window length of five residues. You can change this by selecting Edit > Filter Window Options. The dialog box lets you select the Window Size from 5 to 29 residues. Increasing the window size produces a smoother plot. You can modify the shape of the smoothing window by changing the Edge Weight factor. And you can choose the smoothing function to be a linear moving average, an exponential moving average or a linear Lowess smoothing.

The File menu lets you import a sequence, save the plot that you have created to a Figure file, export the data values in the figure to a workspace variable or to a MAT-file, export the figure to a normal Figure window for customizing, or print the figure.

The Edit menu lets you create a new property, to reset the property values to the default values, and to modify the smoothing parameters with the Configuration Values menu item.

The View menu lets you turn the toolbar on and off, and to add a legend to the plot.

The Tools menu lets you zoom in and zoom out of the plot, to view Data Statistics such as mean, minimum and maximum values of the plot, and to normalize the values of the plot from 0 to 1.

The Help menu lets you view this document and to see the references for the sequence properties included with the Protein Plot window.

Was this topic helpful?