Having trouble connecting MATLAB to Lumerical

8 views (last 30 days)
Marissa Whitby
Marissa Whitby on 2 Nov 2021
Commented: Marissa Whitby on 3 Nov 2021
Hi! I'm trying to connect my 64-bit MATLAB 2019a to Lumerical so that I can use the matlab(); script command in Lumerical. I tried following the instructions on this page https://support.lumerical.com/hc/en-us/articles/360026142074-MATLAB-script-integration-configuration-guide.
I found the libeng file in the MATLAB folder but even after I selected it and Lumerical said it was connected to MATLAB I got errors in Lumerical saying that MATLAB was not connected. I then tried to register the MATLAB software as an automation server by using the !matlab/regserver command in MATLAB as recommended but MATLAB just says busy and never does anything with it (even after several hours). I then went straight to the command window and input "C:\Program Files\MATLAB\R2019a\bin\win64\matlab"/regserver. This gave me the error "Unable to set Registry value for Software\Classes\CLSID\{6B213DCC-D6A6-472B-8E06-472B-8E06-5A84313EFE46}.You may not have sufficient privileges. Re-run MATLAB as a user with Administrator access" However I am the administrator on the computer and I ran it under my account. I also have MATLAB set so it automatically runs as administrator.
Please help. Any information is much appreciated.
  2 Comments
Marissa Whitby
Marissa Whitby on 3 Nov 2021
Hi Walter thank you for your response. I was running it as administrator using the "Run as Administrator" option. It turns out the problem was that there was still a MATLAB 2020 file on my computer and I had to delete it for the connection to my MATLAB 2019 program worked. Thank you again!

Sign in to comment.

Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!