MATLAB Answers

0

Why doesn't the Hardware Setup detect my PARROT Rolling Spider on Windows?

I am trying to use a Parrot Rolling Spider minidrone with MATLAB, but the setup application does not seem to detect it. I think the problem is occurring because MATLAB is unable to find my drone as a mount point. Although the command "usbDevices.getAttachedDevices" shows that the drone is connected, the following commands return an empty cell array:
usbDevices = matlab.hwmgr.internal.hwconnection.USBDeviceEnumerator;
usbDevices.getMountPoints('vendorid','19cf')
The issue occurs only while using Windows. It works out fine on a Linux machine.
I have even tried to manually make a mount point for the drone in Windows (i.e. C:\MountPoints\RS), but to no avail. How do I resolve this issue?

Products


Release

R2017a

1 Answer

Answer by MathWorks Support Team on 9 Oct 2017
 Accepted Answer

This issue occurs on some Windows 10 installations. There are two possible reasons for this issue:
1. The timeout period (typically 60 seconds) might have expired for the Rolling Spider minidrone and hence it would get disconnected from the PC automatically. In this case, you should perform the following steps:
a. Connect the drone back to the host PC.
b. Wait for the LEDs to stabilize to one GREEN and one RED and then search for the minidrone in the setup application. You need to ensure that a drive named ‘Parrot_RS’ is appearing in their drive list. 
2. If you can see a drive, but the drone is still not being detected by the setup, it indicates that the MATLAB USB enumerator APIs are returning NULL values. This might be due to the missing .NET application in the Windows 10 installation. To resolve this issue, please perform the following steps:
a. Navigate to support package root by executing the following commands in the MATLAB command window:
cd(matlabshared.supportpkg.getSupportPackageRoot);
cd toolbox\target\supportpackages\parrot\+codertarget\+parrot\+setup;
b. Replace the "selectDroneFromList.m" and "flashDrone.m" files with the attached files.
c. Delete the "selectDroneFromList.p" and "flashDrone.p" files.
d. Execute the following commands in the MATLAB command window:
clear classses; clear pcode; rehash toolboxcache;

  2 Comments

My bluetooth device is connected correctly, but matble can't find it. >>instrhwinfo('Bluetooth') ans = HardwareInfo (具有属性): RemoteNames: [] RemoteIDs: [] BluecoveVersion: 'BlueCove-2.1.1-SNAPSHOT' JarFileVersion: 'Version 3.12' Access to your hardware may be provided by a support package. Go to the Support Package Installer to learn more. This problem will come across when I use CSR Harmony.
Hi Shixian,
There does not seem to be an issue with the above output that you receive.
Could you tell me if you have completed the hardware setup screens? If you get any error, please share the snapshot here.

Sign in to comment.