Simulink stuck with Robotics Toolbox model initialization

1 view (last 30 days)
I have seen here that there was a problem on Windows machines with matlab2017a. But I am on ubuntu 14.04 and I am using matlab2017b and I have the following problem.
I recorded a rosbag with the following topics:
path: 2018-03-01-15-13-41.bag
version: 2.0
duration: 1:13s (73s)
start: Mar 01 2018 15:13:41.94 (1519913621.94)
end: Mar 01 2018 15:14:55.92 (1519913695.92)
size: 5.8 GB
messages: 25640
compression: none [4359/4359 chunks]
types: geometry_msgs/Pose [e45d45a5a1ce597b249e23fb30fc871f]
geometry_msgs/PoseArray [916c28c5764443f268b296bb671b9d97]
geometry_msgs/TransformStamped [b5764a33bfeb3588febc2682852579b0]
sensor_msgs/CameraInfo [c9a58c1b0b154e0e6da7578cb991d214]
sensor_msgs/Image [060021388200f6f0f447d0fcd9c64743]
topics: /Drones/Pose 1233 msgs : geometry_msgs/Pose
/apriltag/uv_array 1393 msgs : geometry_msgs/PoseArray
/camera/camera_info 2966 msgs : sensor_msgs/CameraInfo
/camera/image_raw 2966 msgs : sensor_msgs/Image
/vicon/boxAprilTag/boxAprilTag 8535 msgs : geometry_msgs/TransformStamped
/vicon/cameraFlea/cameraFlea 8547 msgs : geometry_msgs/TransformStamped
I created a simulink model with only a ROS subscribe block which subscribe to the topic
/apriltag/uv_array
which is a msg of type
geometry_msgs/PoseArray
I then play the rosbag I recorded and when I try to build the model everything is ok. When, instead, I try to run the model this gets stuck into the initializing phase and never gets out of it. How can I solve this problem?
Thanks in advance.

Answers (0)

Categories

Find more on Publishers and Subscribers in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!