Why does the Update Installer fail with no clear error message shown in the log file?

26 views (last 30 days)
When trying to install an update with a standalone installer, the installation process terminates with the message:
Installation failed [1]
There is no other clear indicator of what may be causing the issue. How can I resolve the issue?

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 10 Jun 2022
Edited: MathWorks Support Team on 22 Jul 2022 at 17:10
If the updater installation log file does not show any clear indicator of what is causing the issue, do a search for "skipping" in the log file.
For example, in several cases there are mentions of the Simulink Real Time Toolbox being skipped:
Need to update: toolbox/slrt/target/kernel/XXXXX
Warning: File on disk does not match expected meta data
Warning: meta size: 1526446 meta time: 1503595432 (orig)
Warning: meta size: 1526449 meta time: 1512792246 (new)
Warning: disk size: 1527326 disk time: 1521632126
Warning: Skipping update
This usually means that the file being looked at was modified. There are a few recommended solutions to try:
  1. Reinstalling the toolbox that is affected and then apply the update to a clean installation.
  2. Running the update as an administrator account as permissions issues will also appear as this error.
  3. Disabling any antivirus software
  4. Reinstalling MATLAB with administrative privileges and antivirus software disabled and then attempting the update once more.
  1 Comment
Royi Avital
Royi Avital on 14 Jul 2018
Edited: Royi Avital on 14 Jul 2018
Reinstalling is a mess. Any option to add `force` mode to the updater?
I have this issue for update 4 of R2018a on Linux. The installation of MATLAB is a folder which requires root for write permission. The only program touched those files was Update 3.

Sign in to comment.

More Answers (4)

Justin Ghetti
Justin Ghetti on 19 Jul 2018
Edited: MathWorks Support Team on 9 Jun 2022
If you are still experiencing this issue, please contact MathWorks support:
Kyle Perry
Kyle Perry on 1 Aug 2018
Hello Royi,
Currently there is not, I am forwarding this request internally for future reference though.

Sign in to comment.

kira on 8 Aug 2018
hello, same issue here!!! Any fix?

James Macdonald
James Macdonald on 1 Apr 2019
Turn off your anti-virus software and reinstall Matlab. On my system, the anti-virus software was altering the date modified timestamps at installation, which was triggering the meta data check to fail when trying to update Matlab.

Faheem Ershad
Faheem Ershad on 29 Oct 2019
So I went into the log file and searched for the "Skipping update" line as the support team suggested. For my case, I was getting the "Skipping" a couple lines after a line that listed this as the problematic directory:
That's in your MATLAB/r2018a/ folder by the way.
I went into that directory and saw that there was a -OLD addition at the end of the .dll file. In other words, the file in that directory was named this:
I copied that file in the same directory and removed the -OLD from the end so that the file name ended with the .dll extension. I ran the update installer again and it worked!
Just for context, I was trying to update r2018a (update 1 I believe) to r2018a update 6.




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!