Can we install MATLAB v7.0 on a Windows 10 Operating system through required linux version installation in a virtual box?

55 views (last 30 days)
I am trying to run an old MATLAB code, which requires MATLAB 7.0.1. I have a 64-bit Windows Operating system. However, I would need Windows XP, Windows 2000, or Windows NT 4.0 for me to be able to install MATLAB 7.0.1. Another approach would be to have a Linux - built using Kernel 2.4.x and glibc 2.3.2. The system requirements for all MATLAB versions are given here. Therefore, I am planning to install the required Linux version through virtual box on my Windows system and later install the MATLAB version. However, I am not sure if this is an ideal approach as there are other requirements on the specific Processeors. Please let me know if it is possible to install MATLAB 7.0.1 on my Windows 64 bit operating system through required Linux version installation or if there are better ways of doing it. Thanks.
  4 Comments
Yaswanth Sai Jetti
Yaswanth Sai Jetti on 30 Nov 2020
I received the code from an author of a old paper. It is the source code for a tool which is written in the MATLAB v7.0 with the MATLAB GUI development environment (GUIDE) v2.5 and the MATLAB Symbolic Toolbox v3.1. The author told me that the code would not work in modern releases due to differences in Symbolic tool box. It is a very large code with 10 different files and one of them have more than 2000 lines. When I run the code, it had many errors and did not know where I should start debugging. I thought that if I can run it on the older MATLAB version, I would get a better idea about the code.

Sign in to comment.

Accepted Answer

Priysha LNU
Priysha LNU on 7 Jan 2021
Hi,
MATLAB R2015a and later is supported on Windows 10.
Earlier releases of MATLAB are not supported and are not guaranteed to work on Windows 10.
MATLAB 7.0 (release R14) is fourteen years old. From the System Requirements page the versions of Windows on which it is supported are Windows NT 4.0, Windows 2000, and Windows XP. [The release of Windows Vista was still about four years in the future when that release came out; Windows 10 was even further years away.]
I would recommend you to upgrade your code to run in a more recent release. The Code Analyzer messages that you see in the Editor when you open your files may help you in identifying functions that have been removed since and what should replace them. If you find that you cannot identify a replacement after searching the Release Notes (the Release Notes for releases back to release R14SP2 are available on our website), please ask about a specific function or piece of functionality as an ML Answers post.
In another note, you just might be able to turn on Windows Compatibility Mode for the 7.0 executable. http://www.howtogeek.com/228689/how-to-make-old-programs-work-on-windows-10/
Hope this helps!
Thanks!
DISCLAIMER: These are my own views and in no way depict those of MathWorks.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!