Why getting NaN's and other garbage from interp1?

5 views (last 30 days)
I have had my fair share of times when I got weird results form using interp1. Usually I'd find a hidding NaN somewhere or maybe some weird spline behavior. This time I'm stumped. my source data is clean, no NaNs in my underlying values or desired extrapolated values. I' not extrapolating even. I tried several methods and keep getting weird results. Should be an easy one! I'm getting Nan's up to 20 Hz (b and c are Hz in my case). The rest of the test variable is mostly NaNs with a few non NaN numbers which seem to have little relation to the source data. I can't understand this!
test = interp1(a,b,c);

Accepted Answer

Star Strider
Star Strider on 27 Nov 2021
I am not certain what the problem is (providing the data without the code and interp1 calls is not informative), however unless an interpolation method is provided and 'extrap' is requested, the interpolation functions will return NaN for the extrapolated values (although this varies with the extended-dimension functions). See Extrapolation Using Two Different Methods for details on this.
.
  2 Comments
Star Strider
Star Strider on 28 Nov 2021
No, please keep the Question posted.
I’ve been active here for about eight years total, although not continuously. The same problems keep occurring, and if someone sees this thread it could provide an immediate solution to a similar problem they they would otherwise have to wait to have a response posted for. One of the benefits of Answers is that it’s a repository of such problems and solutions.
.

Sign in to comment.

More Answers (0)

Products


Release

R2021a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!