MATLAB Answers

Java issue with Matlab

90 views (last 30 days)
I messed with the version of Java that I was using in Matlab and then I had some issues, so I tried to delete Matlab and all versions of Java from my machine then reinstall Matlab. According to,
Matlab already has java in it, so I assumed that the fresh install of Matlab would fix the issue. But it did not and I ended up having to install Java and point to it as per the article above just to get Matlab working with Java again.
The issues are these:
1. When I start up Matlab, I get
2. Sometimes it spools red errors and I have to shut Matlab off
3. I loose a lot of the interactive features, for instance; I cannot click on the folder ribon to move through the folders as:
3.b also, sometimes I cannot resize windows.
So, I lost some functionality. How can I run the version of Java that ships with the student version of Matlab?
Thanks!!

Accepted Answer

Mukul Rao
Mukul Rao on 25 Jun 2015
Edited: Mukul Rao on 1 Jul 2015
Hi, yes the cause of this issue appears to be the use of an incorrect JRE . Here is my recommendation - when MATLAB is shipped, the JRE used by the installed product is located in the directory (example for R2015a , win64):
C:\Program Files\MATLAB\R2015a\sys\java\jre\win64\jre
The JRE used by your current running instance of MATLAB can be determined by the output of the following command:
>> java.lang.System.getProperty('java.home')
Ideally, the output from the above command must point to the shipped JRE. I would recommend changing your MATLAB_JAVA environment variable to point MATLAB to use the shipped version of the JRE. This should resolve the issue.
  3 Comments
Huck Febbo
Huck Febbo on 30 Jun 2015
This worked! Thanks!!!

Sign in to comment.

More Answers (1)

Francisco Munoz Grandjean
Francisco Munoz Grandjean on 26 Nov 2020
I have the same problem with Matlab. But I'm using Linux Mind, could someone help me?

Tags

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!