Matlab on Linux: Failed to load module "canberra-gtk-module"

214 views (last 30 days)
I run Matlab on Ubuntu and am told that
Failed to load module "canberra-gtk-module"
What am I to do?

Accepted Answer

Toder
Toder on 6 Jun 2020
This is a known bug but shouldn't affect your ability to use Matlab. See https://www.mathworks.com/support/bugreports/details/1995075

More Answers (3)

M Adomini
M Adomini on 28 Feb 2022
I get same issue on Ubuntu 20.04, 21.10 and 22.04 with matlab 2021a and 2021b.

Tomoki Kaneko
Tomoki Kaneko on 14 Mar 2022
I have the same problem with 2020b.
Then, I ran "sudo apt-get install libcanberra-gtk*', and finished with no problem. But the caution didn't disappere.

Munir
Munir on 2 Jul 2022
I have the same problem but the main concern is that running a .mlx file and trying to visualize some stuff (showdetails(robot))
I get:
"Couldn't create JOGL canvas--using painters"
which I totaly though it was related to the initial problem when launchin matlab
munir@munir-desktop:~/Documents/matlab2022a$ ./matlab
Gtk-Message: 14:06:16.642: Failed to load module "canberra-gtk-module"
I'm running on Ubuntu 20.04

Tags

Products


Release

R2020a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!