How can I run a model in rapid accelerator mode on Linux?

2 views (last 30 days)
When running a model in rapid accelerator mode in Linux (RHEL 6.4), Simulink reports the model error "Unable to find an unused TCP/IP port to connect to the rapid accelerator target for model 'test03'". This error occurs for even the basic model consisting of a single constant block connected to an outport.
Despite the error, Simulink successfully launches a new process and runs the executable, which does not terminate and which consumes 100% CPU time (as reported by top). I have to kill the process manually.
This is apparently a firewall issue ( ); when the same model is first run in rapid accelerator mode on Windows, the Windows Firewall presents me with an option to block or allow the newly-created executable.
I am guessing I need to configure iptables to allow MATLAB to communicate with the rapid accelerator process via TCP. Is that correct? If so, what are the appropriate settings?

Answers (1)

Yu on 2 Jul 2013
Edited: Yu on 2 Jul 2013
I got the same problem. Even if "service iptables stop" been executed, I got the same error


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!