OCR training cannot train data error

7 views (last 30 days)
Abdullah Azzam
Abdullah Azzam on 15 Jul 2021
Answered: Anshika Chaurasia on 15 Sep 2021
Hi All
I have been trying to train ocr to read digital numbers of scale after doing some process on the pictures such as cropping masking...etc. However, When I train the data I, it keeps giving me this error even though the number of samples for training is more than requried I also tried to increase that but same issue still happening. How may I fix this issue so that I can train the ocr to accuratly read my digits. I have tried to use the build in liberary for the ocr to read the digits but it keeps giving either wrong readings or no readings at all.
  1 Comment
Abdullah Azzam
Abdullah Azzam on 15 Jul 2021
on the help center they have this note regards this topic. But they didn't mention how to check that so I can test it.

Sign in to comment.

Answers (1)

Anshika Chaurasia
Anshika Chaurasia on 15 Sep 2021
Hi Abdullah,
Sometimes other Tesseract installations set an environment variable that can conflict with how MATLAB searches for Tesseract data files. You can check if this is set by doing the following from MATLAB:
The result of that command should be an empty string.
If it is not an empty string, then you should execute this command prior to running the "ocrTrainer":
Hope it helps!




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!