Product Requirements & Platform Availability for MATLAB Compiler

Supported Platforms

Mac, Windows, Linux

Product Requirements

  • Requires MATLAB
  • MATLAB Compiler SDK works with MATLAB Compiler to produce deployable components. They are ineligible for use with MATLAB Compiler because a deployed application built with MATLAB Compiler cannot itself use MATLAB Compiler SDK to produce additional components.

Supported Third-Party Compilers

Supported Language Interfaces

  • C11 and earlier versions
  • C++14 and earlier versions
  • Python 2.7, 3.6, 3.7

Introduced in R2015a

View requirements for another product: