Main Content

ROS System Requirements

ROS 1 Noetic Ninjemys Requirements

Since R2022a, the ROS Toolbox supports the ROS Noetic Ninjemys distribution for ROS.

Platforms

  • Windows® 10 only

  • Linux® — Ubuntu 20.04 recommended

  • macOS

For more information about ROS Noetic support, see their Target Platforms page.

ROS Node Deployment and Custom Messages

When generating custom messages for ROS, or deploying ROS nodes from MATLAB® or Simulink®, you must build the necessary ROS packages. This requires you to have Python®, CMake, and a C++ compiler for your platform.

Python Version 3.9

  • To connect to ROS networks with the rosinit function, you must install and set up Python 3.9.

  • To check your Python version, use the pyenv function.

    pyenv
    ans = 
      PythonEnvironment with properties:
    
              Version: "3.9"
           Executable: "C:\Python39\python.exe"
              Library: "C:\Python39\python39.dll"
                 Home: "C:\Python39"
               Status: NotLoaded
        ExecutionMode: InProcess
  • If your Python interpreter is set to a different version, restart MATLAB and set the version with pyenv.

    pyenv('Version','3.9')

CMake

  • Download and install CMake 3.16.3+.

C++ Compilers

ROS 1 Melodic Morenia Requirements

From R2020b to R2021b, the ROS Toolbox supports the ROS Melodic Morenia distribution for ROS.

Platforms

  • Windows — Windows 10 recommended for all ROS distributions. For ROS Melodic, only Windows 10 is supported.

  • Linux — Ubuntu 18.04 recommended.

  • Mac OS X

For more information about ROS Melodic support, see their Target Platforms page.

ROS Node Deployment and Custom Messages

When generating custom messages for ROS, or deploying ROS nodes from MATLAB or Simulink, you must build the necessary ROS packages. This requires you to have Python, CMake, and a C++ compiler for your platform:

Python Version 2.7

  • To connect to ROS networks with the rosinit function, you must install and set up Python 2.7.

  • To check your Python version, use the pyenv function.

    pyenv
    ans = 
      PythonEnvironment with properties:
    
              Version: "2.7"
           Executable: "C:\Python27\pythonw.exe"
              Library: "C:\windows\system32\python27.dll"
                 Home: "C:\Python27"
               Status: NotLoaded
        ExecutionMode: OutOfProcess
  • If your Python interpreter is set to a different version, restart MATLAB and set the version with pyenv.

    pyenv('Version','2.7')

CMake

  • Download and install CMake 3.15.5+.

C++ Compilers

ROS 2 Foxy Fitzroy Requirements

Since R2022a, the ROS Toolbox supports the Foxy Fitzroy distribution for ROS 2.

Platforms

  • Windows 10 only

  • Linux — Ubuntu 20.04 recommended

  • macOS — Mojave (10.14)

For more information about ROS 2 Foxy support, see their Foxy Fitzroy page.

ROS 2 Node Deployment and Custom Messages

When generating custom messages for ROS 2, or deploying ROS 2 nodes from MATLAB or Simulink, you must build the necessary ROS 2 packages. This requires you to have Python, CMake, and a C++ compiler for your platform.

Python Version 3.9

  • Install and set up Python 3.9.

  • To check your Python version, use the pyenv function.

    pyenv
    ans = 
      PythonEnvironment with properties:
    
              Version: "3.9"
           Executable: "C:\Python39\python.exe"
              Library: "C:\Python39\python39.dll"
                 Home: "C:\Python39"
               Status: NotLoaded
        ExecutionMode: InProcess
  • If your Python interpreter is set to a different version, restart MATLAB and set the version with pyenv.

    pyenv('Version','3.9')

CMake

  • Download and install CMake 3.16.3+.

C++ Compilers

ROS 2 Dashing Diademata Requirements

From R2020a to R2021b, the ROS Toolbox supports the Dashing Diademata distribution for ROS 2.

Platforms

  • Windows 10 only

  • Linux — Ubuntu 18.04 recommended

  • macOS — Sierra (10.12.x)

For more information about ROS 2 Dashing support, see their Dashing Diademata page.

ROS 2 Node Deployment and Custom Messages

When generating custom messages for ROS 2, or deploying ROS 2 nodes from MATLAB or Simulink, you must build the necessary ROS 2 packages. This requires you to have Python, CMake, and a C++ compiler for your platform.

Python Version 3.7

  • Install and set up Python 3.7.

  • To check your Python version, use the pyenv function.

    pyenv
    ans = 
      PythonEnvironment with properties:
    
              Version: "3.7"
           Executable: "C:\Python37\pythonw.exe"
              Library: "C:\windows\system32\python37.dll"
                 Home: "C:\Python37"
               Status: NotLoaded
        ExecutionMode: OutOfProcess
  • If your Python interpreter is set to a different version, restart MATLAB and set the version with pyenv.

    pyenv('Version','3.7')

CMake

  • Download and install CMake 3.15.5+.

C++ Compilers

Related Topics