MATLAB Answers

Info

This question is closed.

Matlab(R2014b) compatible with OS X Yosemite?

1 view (last 30 days)
Andreas Fenk
Andreas Fenk on 20 Oct 2014
Closed: John Kelly on 22 Oct 2014
I want to upgrade my MAC to OS X Yosemite! Is my MATLAB R2014b (student version) compatible with this OS?

  0 Comments

Answers (1)

Bruno Pop-Stefanov
Bruno Pop-Stefanov on 20 Oct 2014
Edited: John Kelly on 22 Oct 2014
Hi Andreas,
To be clear: MATLAB R2014a is the latest release available to students:
If you are using MATLAB R2014b (not the student version), MATLAB is supported on Mac OS X 10.10 (Yosemite).
For the most accurate information regarding Yosemite and PreR2014b releases of MATLAB:
For more information, please refer to the platform roadmap:
MATLAB R2012a through R2014a (R2012a, R2012b, R2013a, R2013b and R2014a) may trigger a Java exception and abrupt exit upon startup. Once patched, they appear to work normally, but compatibility cannot be guaranteed. The patch can be downloaded from the bug report that can be accessed from the link below:
Launching MATLAB on certain versions of Mac OS X 10.10 (Yosemite) displays the following error message in a dialog:
"You can't use this version of the application"
For more information regarding this, please see the Bug Report linked below:
Versions of MATLAB earlier than R2012a are *not *compatible with Mac OS X 10.10 (Yosemite).

  0 Comments

Sign in to answer this question.

Products