EPS export problems in R2014b

6 views (last 30 days)
Remco on 21 Oct 2014
Commented: Qisq on 12 Mar 2018
I have recently upgraded to R2014b (Linux version), and now exporting figures to eps seems to have a strange bug. If I try the following from the command line, I get the expected outcome. plot(1:3,2:4);print(gcf,'-depsc', 'testFromCommandLine.eps');
However, if I run the exact same script from the editor window, I get an eps file with a graph that occupies the top left corner of the canvas.
The only code in the script is: close all; plot(1:3,2:4); print(gcf,'-depsc', 'testFromScript.eps')
The screenshots of the two generated eps files are embedded.
This happens in all these three cases: pressing the RUN button in the editor, selecting the code and running the selection and executing the script (just typing the script's name without .m) from the command line.
William Thompson
William Thompson on 29 Oct 2014
UPDATE: The following code will *almost* work (see comments below):
epsfig = hgexport('factorystyle');
epsfig.Format = 'eps';
x = randn(10,1);
y = randn(10,1);
xlabel('X Label','FontSize',30)
ylabel('Y Label','FontSize',30)
set(gcf,'OuterPosition',[0.1 0.1 0.7 0.7])
It appears that hgexport is a lower-level function used by the File > Save As command (hence explaining the observations of Remco). The file produced with the above code snippet renders OK on Mac (Mavericks). BUT: when the file is opened, it gives a warning about font conversion.
There are also some cross-platform issues. If you use latex symbols, e.g.,
title('\Delta Title','FontSize',30)
this will not render. Changing to
title('$\Delta$ Graphics','FontSize',30,'interpreter','latex');
will render fine on the Mac, but gives bizarre results (missing axis tick labels) on Windows (XP).
Basically, Mathworks needs to take a hard look at this. EPS graphics are near-universal for scientific publication, and if 2014b cannot do it properly, that is a major issue.

Sign in to comment.

Accepted Answer

Bruno Pop-Stefanov
Bruno Pop-Stefanov on 22 Oct 2014
Can you check the 'PaperPositionMode' property of the figure before printing it in each case? Try setting it to 'auto' before printing:
>> set(gcf, 'PaperPositionMode','auto')
Do you see the same behavior when printing to something else than .eps, for example .png?
>> print -dpng test.png
Leonardo on 22 Nov 2014
I am having the same problem, too. It is infuriating, and making it impossible to proceed with writing a paper for a journal that only accepts vector figures.
Not to mention, the file sizes are outrageously huge in 2014 compared to 2012.

Sign in to comment.

More Answers (7)

Jonathan on 24 Oct 2014
Hi, I just upgraded to 2014b on OS X and neither of these fixes stops the .eps from being bounded by a full page when saved. I also tried changing groot as suggested, and even giving exact page sizes to match my figure window size but using either command line or script saving via saveas or print always returns the full page bounding box. Any other tips/things to try?
Using the dialog saveas works fine, why Matlab haven't implemented that as the default behaviour of saveas I have no idea.
  1 Comment
Leonardo on 22 Nov 2014
Same here. I'm having the same problem and it is infuriating. Code which worked in 2012a now produces garbage pictures in 2014b. I've wasted hours and hours trying to get the old behavior back, to no avail. Also, the EPS files are now 10 times larger in file size than previous. Put it back the way it was!

Sign in to comment.

CHJY on 20 Jul 2015
Try this:
  1. set(gcf,'paperpositionmode','auto')
  2. print(gcf,'-depsc2','-loose','test.eps');
The '-loose' option affects how matlab defines the bounding box in the eps file.
Qisq on 12 Mar 2018
Worked for me! Thank you Sir. Turns out MATLAB outputs tight bounding box that is inconsistent across different figures, so when I use epstopdf on them they are cropped to different dimensions!

Sign in to comment.

Gideon simpson
Gideon simpson on 3 Nov 2014
I have the additional problem on OS X 10.9 that when I save figure eps figures (with latex labels) and open them in Preview.app, I get:
PostScript Conversion Warning:
Converting the PostScript file "test.eps" produced the following warnings: · CMR10 not found, using Courier. · CMMI10 not found, using Courier.
  1 Comment
Dawson Baker
Dawson Baker on 8 Nov 2015
I have the same problem, and have not been able to figure it out.

Sign in to comment.

Viktor Vorobev
Viktor Vorobev on 15 Feb 2015
I also have another problem. After exporting to EPS I used to edit the figure with CorelDRAW and everything was OK. But after exporting to EPS in 2014b (Win, x64), my CorelDRAW (X5, Win, x32) hangs while trying to import this EPS file.
With 2013b (Win, x64) everything works great.

PaVi90 on 27 Feb 2015
Same problem here. Is it possible that I have to downgrade to the blurry R2014a because of this? Unfortunately I desperately need exports in EPS in an automatic manner... :(

Daniel on 25 Jun 2015
Edited: Daniel on 25 Jun 2015
This problem persists in Matlab 2015a. Code which previously generated a correctly sized eps no longer does so. Instead, I get a letter-sized eps containing a fragment of my figure, with the box spilling over the edge. Hence, the visualization software I wrote is essentially broken for generating publication-quality vector graphics. A fix is desperately sought.

Shannon on 23 Nov 2017
Still having the same issues with 2016.
  1 Comment
Jan on 23 Nov 2017
@Shannon: I find several problem descriptions and suggestions for solutions. Please explain, what exactly "the same issue" is, preferably with a small code example.

Sign in to comment.


Find more on Graphics Performance in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!