Out of memory error during insertion of data in database

4 views (last 30 days)
I am trying to establish database connectivity with MS Access in matlab using ODBC connection. Got success in connectivity. For first 2-3 times I got success in inserting data.Then i changed datatype of some of the fields of my table in MS access and accordingly changed query in matlab code, but now it is giving error ' out of memory' while inserting data. please help .
I have tried same again by creating another table in same database with 2 field. It is not giving error now inserting but giving same error when i am trying to execute 'Select * from t2' query.

Answers (1)

Chad on 7 Sep 2017
Responding to a 2 year old issue, but I can also replicate this issue. The problem comes when tables have varchar(max) as a column type. changing this to varchar(1000) fixes my issue, but opens up possible issues later on. Also switching to a JDBC connection while still using varchar(max) fixed the problem as well. Only the ODBC connection was an issue.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!