MATLAB Answers

error conected arduino mega 2560 with simulink r2019B

9 views (last 30 days)
Hello everyone I am working with arduino mega 2560 and linking it with simulink by external mode, I have the r2019b version but every time I am going to run my program with the external mode this error appears
the model that you are trying to run in external mode does not match the application running on your target. checksum test (target_data_map) failed. the host model's structural checksum is [1380959609, 1364613779, 4133718802, 3635779683] and the target application's structural checksum is [3140615652, 2212887576, 351826669, 3173125374]. rebuild the model, run it on your target, and start external mode simulation again
I've been finding out but there's still no solution to this problem, I appreciate the collaboration Thank you

  0 Comments

Sign in to comment.

Accepted Answer

Shashwat Bajpai
Shashwat Bajpai on 1 Oct 2019
Edited: Shashwat Bajpai on 1 Oct 2019
According to my understanding the “mismatch” error is possible because of three reasons:
  • The correct board is not selected in the Hardware Implementation section of Model Parameters.
  • The functions/blocks being used do not support codeGen.
  • The required support packages are not installed.
I would be in a better state to help, if I could look at the model you are trying to implement.
Please refer the following documentation for further information:

  0 Comments

Sign in to comment.

More Answers (0)

Sign in to answer this question.

Products


Release

R2019b