MATLAB Answers

generating audio plugins is not supported in glnxa64

4 views (last 30 days)
Hello guys!
I seem to be having an issue when attempting to validate and generate a plugin in Linux. It comes up with ''generating audio plugins is not supported in glnxa64'' error. Any idea how to solve this? MATLAB online has the same issue.
Thank you in advance for the help!

  0 Comments

Sign in to comment.

Accepted Answer

Charlie DeVane
Charlie DeVane on 28 Jan 2020
Hi Angeliki,
In MATLAB releases before R2019b, validateAudioPlugin and generateAudioPlugin do not support Linux.
As of release R2019b
  • validateAudioPlugin supports Linux.
  • generateAudioPlugin supports Linux, but only with the -juceproject switch. This produces C/C++ source code for the plugin along with a .jucer project file for use with JUCE 5.3.2. It does not compile the plugin into a binary. The -juceproject switch requires a MATLAB Coder license.
hope this helps,
Charlie

  1 Comment

Angeliki Mourgela
Angeliki Mourgela on 29 Jan 2020
Hey Charlie! This helps a lot thank you very much for your response!
Angeliki

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!