Force Simulink Embedded Coder to do a simple cast when converting float to uint16?

13 views (last 30 days)
I've got a problem with Embedded Coder trying to be too helpful and it's breaking my code.
I want to simply cast a floating point to a uint16 (using the convert block).
Embedded Coder generates this monstruosity:
rtb_DataTypeConversion[0] = (uint16_T)(int32_T)fmod((int32_T)floor(fmax(0.0, fmin(65535.0, PWMGen_TestCode_B.Add_b))), 65536.0);
Which for some reason, when I run on my target (Aurix TC299), just returns 0 all the time (it doesn't like fmod...) I've also tried every option and blocks around, adding saturation, floor etc, it still wants to fmod which breaks my code.
I've hand modified my code to do:
rtb_DataTypeConversion[0] = (uint16_T)(PWMGen_TestCode_B.Add_b);
Which is a simple cast to uint16, and it works! It's as simple as that.
How can I force Simulink/Embedded coder to only generate a simple cast? I don't want to have to hand modify my code everytime, this kind of defeats the point, plus it takes ages...
Thanks for your help.
edit: Solution thanks to Les Backman

Answers (1)

Birdman
Birdman on 26 Mar 2020
Why don't you use a MATLAB Function block and write this line inside it? For example:
y=uint16(x);
This line should go inside MATLAB Function instead using Data Type Conversion block.
  5 Comments
Quentin Coret
Quentin Coret on 26 Mar 2020
I've checked with my debugger, the tOn/tOff times are all calculated correctly, they are in number of GTM counts (internal CPU timer, so they'll always be greater than 1).
Example with my modified code that works: On the right side watch window are the result of the math calculation. On the left side are the results of the data conversion.
When I let Embedded Coder do it's thing, the table rtb_DataTypeConversion is all zeroes.
Here is the data convert mask (I've tried pretty much all the different options, it still does the same).

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!