Matlab 2020b won't open on Mac OS Big Sur

234 views (last 30 days)
Laura Hobbs
Laura Hobbs on 16 Nov 2020
Commented: Craig Branch on 1 Nov 2021
I've recently updated to Matlab 2020b, which has worked fine for a number of weeks. I have updated my Mac OS to Big Sur this weekend, and Matlab 2020b now won't open (not excluding the possiblity that this could be a coincidence).
The icon appears for a second or so, as if it is loading up, and then disappears. I have tried restarting my computer, reinstalling Matlab, and reinstalling Java (following suggesitons on previous posts). Any recommnedations would be very welcome!
Thank you.
  1 Comment
Selen Dalgan
Selen Dalgan on 7 Feb 2021
i have the same exact issue and it sucks

Sign in to comment.

Accepted Answer

Ameer Hamza
Ameer Hamza on 16 Nov 2020
See what happen when you try to start it from command line. Run following line in terminal
/Applications/MATLAB_R2020b.app/bin/matlab
  2 Comments
Ameer Hamza
Ameer Hamza on 16 Nov 2020
I recently updated to Big Sur but didn't face this problem. So I am not able to try anything to solve this. Maybe create a symlink on the desktop so you can launch MATLAB by double-clicking it. For example
ln -s /Applications/MATLAB_R2020b.app/bin/matlab ~/Desktop/matlab

Sign in to comment.

More Answers (5)

Dmitry Savransky
Dmitry Savransky on 22 Dec 2020
I just ran into this, and it appears to be a disk access issue (same thing - can't launch from icon but can launch from command line). To fix, go to Preferences>Security & Privacy>Full Disk Acccess, unlock, and click the check box by MATLAB, and it should start launching via the dock icon once more.
  10 Comments
Shahad Albrahim
Shahad Albrahim on 30 Sep 2021
Thank you SIR! Trust me when I say I never comment but you just helped solve the problem that Mathworks IT guy couldn't solve so, I needed to show respect.
Have a good day :)

Sign in to comment.


Alperen kilic
Alperen kilic on 14 Dec 2020
ı am using big sur on 2019 mac pro base model. when i click matlab, the pc is not responding.

John D'Errico
John D'Errico on 2 Jan 2021
Edited: John D'Errico on 2 Jan 2021
The simple solution of course to resolve any problems is to use R2021. It seems to run nicely on Big Sur. That is, given we are in 2021.
  1 Comment
Nanny Wermuth
Nanny Wermuth on 23 Jan 2021
I cannot see any version 2021 on mathworks.com, so how did you access it?

Sign in to comment.


thomas greenhill
thomas greenhill on 3 Feb 2021
I'm also having this problem.
When I originally updated to Big Sur, I was able to get R2021a to open by changing the Full Disk Access settings as Dmitry suggested.
Big Sur automatically updated again last night, and I'm now on version 11.2, and MATLAB won't open this morning. The logo pops up and stays open, but the IDE never presents itself. The disk privileges fix that worked last time doesn't work anymore. I can't even open R2021a from the command line with sudo privileges by typing:
sudo "/Applications/MATLAB_R2021a.app/bin/matlab"
in terminal.
Is there a permanent fix for this? I've honeslty found Big Sur extremely buggy. Have others had a similar experience with the updated OS?
  2 Comments
Arun Tangirala
Arun Tangirala on 15 Feb 2021
Btw, I am using updated Big Sur (Mac OS 11.1) and MATLAB R2020b.

Sign in to comment.


thomas greenhill
thomas greenhill on 12 Feb 2021
Update:
If you are connected to an external monitor, try unplugging it, opening up MATLAB with your laptop screen open, then plugging monitor back in.
This solved it for me and it appears MATLAB is still struggling with some screen-level events on macOS.
I hope this will help someone in the future!
  2 Comments
Craig Branch
Craig Branch on 1 Nov 2021
Incredible is right - this just fixed the same problem for me - upgraded to big sur 11.5 and matlab would stall at the logo. Using StarTech's Diplay-Link 2-monitor device, which Matlab seems to have a problem with. Ugh.
After matlab opens, turn the display-link back on an all is OK.

Sign in to comment.

Products


Release

R2020b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!