MATLAB Answers

Errors after converting project from 2019b to 2017a

21 views (last 30 days)
Hello,
I had to downgrade a simulink project including matlab scripts from version 2019a to 2017b. The original version works fine, however, I get some odd errors when running the 2017b version.
The first error I faced when I ran the simulink model came from a called script file:
So I went into that setup_steer.m file and ran it:
I then verified the path and confirmed that it was right. So, I decided to replace the double brackets for single ones like this instead:
addpath('matGeom/matGeom/')
It solved the error, however, a new one appeared further away, a polyshape error:
This is the line where the error came from:
s.rect = polyshape(0.5*[-1, -1;0,-1; 1, -1; 1,0; 1,1; 0,1; -1,1]*diag([s.dist_turnabout, s.rect_height]) + [s.dist_turnabout/2, 0] + s.global_offset, 'KeepCollinearPoints', true, 'Simplify', false);
So I keep trying to solve errors these but get new polyshape errors. Is there a version issue with polyshape ? Is looking at every error one by one the only way to solve this issue?
Thank you

  0 Comments

Sign in to comment.

Accepted Answer

Amrtanshu Raj
Amrtanshu Raj on 24 Dec 2020
Hi,
The reason you are facing this issue is because the 'KeepCollinearPoints' Parameter for polyshape function was introduced after 2017b. You can check the polyshape 2017b and 2019b documentaion.

  0 Comments

Sign in to comment.

More Answers (0)

Products


Release

R2017b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!