MATLAB Answers

Error running MATLAB Parallel Server toolbox "Admincenter"

12 views (last 30 days)
Jason Vest
Jason Vest on 14 Jan 2021
Edited: Jason Vest on 15 Jan 2021
I've installed MATLAB R2020b on RHEL 7.8. I've confirmed that the MATLAB and parallel server licenses are correct and have no licensing errors. When I execute <matlabroot>/toolbox/parallel/bin/admincenter, I get the folloiwng error:
<matlabroot>/sys/java/jre/glnxa64/jre/bin/java: symbol lookup error: <matlabroot>/bin/glnxa64/../../sys/os/glnxa64/ undefined symbol __cxa_thread_atexit_impl
It looks like cxa_thread_atexit_impl is within the library, but the symbol isn't defined within the library and should be defined elsewhere. I've already tried a fresh install and get the same error. Any help would be appreciated.

Accepted Answer

Jason Vest
Jason Vest on 15 Jan 2021
Edited: Jason Vest on 15 Jan 2021
Resolved via Tech Support. For future posterity, issue was specific to RHEL 7 (maybe CENTOS) using an older library than MATLAB expects. Solution was to point to MATLAB's copy of newer library in <matlabroot>. I modified both /etc/bashrc and <matlabroot>/toolbox/parallel/bin/ to have the following line:
export LD_PRELOAD="<matlabroot>/bin/glnxa64/"

More Answers (1)

Raymond Norris
Raymond Norris on 15 Jan 2021
I would suggest contacting Technical Support (support@mathworkscom). They ought to be able to help with this and with your other posting about startworker.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!