Simulink/Speedgoat error - slrt_make_rtw_hook

53 views (last 30 days)
I wish to run a trivially simple simulink model on the SpeedGoat real time system. However, upon model build, I encounter an error as seen in the picture below.
"the call to slrt_make_rtw_hook, during the exit hook generated the following error: Cannot write to destination : C:\Users\USERNAME\Desktop\test.mldatx. Use the 'f' option to override."
I am running R2017b on a Windows 7 machine.
I have tried updating the kernel using speedgoatkerneltransfer.
slrtpingtarget returns success, and the target properties found in the real-time explorer have been set. The model parameter settings are also shown below.
Does anyone have any suggestions to try to get this running?

Accepted Answer

jesse on 7 Nov 2018
UPDATE: I copied the slx file into a different folder, and the build was successful. Not sure why, but it worked.

More Answers (1)

Diego Kuratli
Diego Kuratli on 27 Jan 2023
I would recommend using MATLAB Projects to avoid such issues and have a proper management of the various files and build folders:

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!